Extreme Hesitation Before Warm Up

  • Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Randman1

New Member
Jun 11, 2019
2
0
1
Truck Year
Not Listed
My EcoDiesel has an extreme hesitation before the engine is fully warmed up. I have to depress the pedal to almost 1/2 throttle to get it to move at a normal pace. Once it hits around 2000 rpm it's like someone has ignited an afterburner.

Any one else experience this problem? My truck did not do this when it was new and is slowly getting worse.

Note that when it is fully warmed up, there is no hesitation what so ever.
 

cs in Alabama

Active Member
Feb 21, 2019
486
113
43
Truck Year
2015
Take out the MAP sensor and EGR diffuser tube and clean them. Then report back and tell us if it worked. I think it might. Thanks!
 

Randman1

New Member
Jun 11, 2019
2
0
1
Truck Year
Not Listed
I probably should have mentioned that this is a 2018 with only 10,000 miles on it and has been showing symptoms of this for the last 4,000 miles. I just figured it was because of cold winter temperatures but now we are seeing temps in the 90's and is does it until it's warm.
 

paulm37

New Member
Jun 10, 2019
4
0
1
37
Sacramento
Truck Year
2016
My truck has the same behavior as you described it started yesterday after EcoDiesel emission reflash. I drove home and couldn't believe how terrible the response was. Cleaned EGR tube and the sensor last night so far no difference in performance 150 miles driven since cleaning.
 

cs in Alabama

Active Member
Feb 21, 2019
486
113
43
Truck Year
2015
My truck has the same behavior as you described it started yesterday after EcoDiesel emission reflash. I drove home and couldn't believe how terrible the response was. Cleaned EGR tube and the sensor last night so far no difference in performance 150 miles driven since cleaning.
Did you clean the MAP sensor though?
 

cs in Alabama

Active Member
Feb 21, 2019
486
113
43
Truck Year
2015
I think then, that the new software just makes it very slow until the truck gets hot. I would look at one of the two major engine tunes. They both eliminate turbo lag along with many other benefits.