Glow plug issues

  • Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

evad30

New Member
Jan 6, 2021
9
0
1
PA
Truck Year
2014
Hello, I have an issue I cant figure out.. Started with GP#4 CEL, replaced it.. good for a couple weeks.. CEL back on for same plus P06BC... Ordered and replaced the controller.. Fixed... for 2 days.. CEL back on for all the same.... Anyone else have this issue and if so what was the fix?? Thank You
 

Tremper126

Moderator
Staff member
Supporting Member
Feb 15, 2019
576
224
43
Partlow, Virginia
Truck Year
2014
Sounds to me like the wiring may have an issue. P0674 was my code along with the p06bc. If you continue to drive it do anymore codes come along?
 

evad30

New Member
Jan 6, 2021
9
0
1
PA
Truck Year
2014
Sounds to me like the wiring may have an issue. P0674 was my code along with the p06bc. If you continue to drive it do anymore codes come along?
No other codes... When I clear them, It may go a day or so... then back on
 

Tremper126

Moderator
Staff member
Supporting Member
Feb 15, 2019
576
224
43
Partlow, Virginia
Truck Year
2014
Mine would go a few days without throwing them, longest was a month. I’d check over the wiring and see if you see anything out of the normal. Unless the glowplug out of the box was bad or the connection on the glowplug itself is sloppy and not making good contact
 

evad30

New Member
Jan 6, 2021
9
0
1
PA
Truck Year
2014
Mine would go a few days without throwing them, longest was a month. I’d check over the wiring and see if you see anything out of the normal. Unless the glowplug out of the box was bad or the connection on the glowplug itself is sloppy and not making good contact
This vehicle is so hard to find information on.. No wiring diagrams.etc.... Unless you spend big $$ for the service book on dvd
 

Tremper126

Moderator
Staff member
Supporting Member
Feb 15, 2019
576
224
43
Partlow, Virginia
Truck Year
2014
Tell me about it lol start at the plug and trace your wiring harness back. Unless you changed the wrong plug out which could be a possibility too
 

evad30

New Member
Jan 6, 2021
9
0
1
PA
Truck Year
2014
Tell me about it lol start at the plug and trace your wiring harness back. Unless you changed the wrong plug out which could be a possibility too
Negative.. it said plug 4... front drivers side... I did check it with Ohm Meter,, was at .4.. which new one read .2 I dont think it was even bad..
 

evad30

New Member
Jan 6, 2021
9
0
1
PA
Truck Year
2014
Ok, I metered the plugs... #1 plug was .221v and plug #4 read 124.3 mv... I put new glow plug in and grounded it... it lit up.. I put the old old in the plug and grounded... did not lite!! I see there are several different part numbers for the same looking plug..The one I used first was only $21 on amazon.. I ordered another with a different part number from Amazon and it was $57..
 

Tremper126

Moderator
Staff member
Supporting Member
Feb 15, 2019
576
224
43
Partlow, Virginia
Truck Year
2014
I went to the dealer for mine. It was around 60-70$ I may still have the receipt with the part number but I doubt it