• Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

New ecodiesel owner ETC problem!

Shawn Mills MD

New Member
Feb 12, 2017
6
1
Truck Year
2016
Hi. Picked up new RAM 1500 Ecodiesel down south and drove it 1200 miles home. Absolutely love the truck after previous 10 years wit a duramax crew cab!

Ride home 26.2 and 27.3 MPG running up the blue ridge and Appalachian mountains over two tanks driving home.

This week on 900 mile round trip first half of drive including crossing Berkshires empty without trailer went great.

Coming home however loaded with 800 Lbs towing tandem axle surge hydraulic trailer (UHaul 6X12') lost power in snowstorm coming down east side of Berkshires and couldn't maintain over 20 MPH on flat with CEL and ETC lights on but not flashing.

Momentary return of power then repeat loss. Bad situation in snow storm, 200 miles from home!

Pulled off at Chicopee exit with Closed(Sunday) RAM dealer at end of MassPike exit ramp.

Several restart did not reset CEL or ETC lights. Looks like rental to get home and leave truck/Trailer at dealer!

What should I expect?
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,938
1,025
Truck Year
Not Listed
Hi. Picked up new RAM 1500 Ecodiesel down south and drove it 1200 miles home. Absolutely love the truck after previous 10 years wit a duramax crew cab!

Ride home 26.2 and 27.3 MPG running up the blue ridge and Appalachian mountains over two tanks driving home.

This week on 900 mile round trip first half of drive including crossing Berkshires empty without trailer went great.

Coming home however loaded with 800 Lbs towing tandem axle surge hydraulic trailer (UHaul 6X12') lost power in snowstorm coming down east side of Berkshires and couldn't maintain over 20 MPH on flat with CEL and ETC lights on but not flashing.

Momentary return of power then repeat loss. Bad situation in snow storm, 200 miles from home!

Pulled off at Chicopee exit with Closed(Sunday) RAM dealer at end of MassPike exit ramp.

Several restart did not reset CEL or ETC lights. Looks like rental to get home and leave truck/Trailer at dealer!

What should I expect?

Really hard to say without the actual code # that's stored.

Some have had problems with the harness that runs into the transmission coming lose and/or the connection just not good.

Welcome to the forum!
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,938
1,025
Truck Year
Not Listed

Shawn Mills MD

New Member
Feb 12, 2017
6
1
Truck Year
2016
Thanks for the advice. After "limping home dealer had truck 7 hrs. CEL for "fuel contamination" but fuel checked out fine. Dealer reflashed software with complete correction of problem and addition of some hose clamps to ? Air intake/? Fuel system.

I guess we will see if that fixed it. Drives like a dream again!
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,938
1,025
Truck Year
Not Listed
Thanks for the advice. After "limping home dealer had truck 7 hrs. CEL for "fuel contamination" but fuel checked out fine. Dealer reflashed software with complete correction of problem and addition of some hose clamps to ? Air intake/? Fuel system.

I guess we will see if that fixed it. Drives like a dream again!

Good to hear!
 

Patrick Feld

New Member
Oct 10, 2018
1
0
Truck Year
2015
Did you happen to hit the brake and gas at the same time? Buy a code reader clear it yourself
 
Top