Ok, so I have owned my 2015 Ram for 2 days and ECT light comes on

  • Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

mlgdave

New Member
Jul 30, 2020
10
2
3
Central California
Truck Year
2015
I have now had my 2015 Dodge Ram 1500 Ecodiesel for 2 days. (Needed a truck in a hurry, and bought this one). I drove 300 miles today on the freeway and then all of a sudden the ECT light comes on. Still able to do 80 MPH, still able to rev to 4,000 RPM but I did notice lack of power.
So, questions and looking for opinions.
I am past warranty so NP doing a delete (maybe) based on answers
#1 - is a delete and Edge tuner a recommended possible solution (I won't ever need a smog redone)
#2 - does the American Trucks pedal commander get rid of issue?
#3 - GDE is no longer, is Sofaking any good (I see they are banned on another forum), or is there any other alternative recommended tune that will eliminate it?
#4 - I will probably get a Bosch OBD and do a reset/clear error code and see what happens (get the ACTUAL error code #)

Thanks!
Dave
 

TC Diesel

Well-Known Member
Jul 14, 2016
1,516
413
83
Blaine
www.tcdiesel.com
Truck Year
2015
Get Alfa-OBD for code clearing, SFK seem liked By many, GDE does offer CAA tunes, Dave in the end you will be spending about $1-3K in repairs, I am also Banned from that same forum, Its what I consider an Honor.
 
Last edited:

Tremper126

Active Member
Feb 15, 2019
329
129
43
Partlow, Virginia
Truck Year
2014
Pedal commander only tricks the truck into thinking your riding the pedal harder from what I could gather from reviews, truck is a ticking time bomb if your egr is still operational. Gdes old tunes used to stop the egr from functioning, pretty sure their new lineup doesn’t. I’ve had sofaking for just over 10k and the truck is phenomenal. Still stage 1 so truck is quiet but my egr is gone so no risk of a fire. What code did it throw?
 

mlgdave

New Member
Jul 30, 2020
10
2
3
Central California
Truck Year
2015
Truck ran fine until I got to Socal and rush hour. About 1 hour of slow speeds, then when rush hour was over and i sped back up (within 20 minutes) is when the code came on. I am new to having a truck with DEF and I did notice that the gauge barely moved on a 350 mile trip from full. How much DEF gets used in a tank of fuel?
 

mlgdave

New Member
Jul 30, 2020
10
2
3
Central California
Truck Year
2015
Pedal commander only tricks the truck into thinking your riding the pedal harder from what I could gather from reviews, truck is a ticking time bomb if your egr is still operational. Gdes old tunes used to stop the egr from functioning, pretty sure their new lineup doesn’t. I’ve had sofaking for just over 10k and the truck is phenomenal. Still stage 1 so truck is quiet but my egr is gone so no risk of a fire. What code did it throw?
P0299
 

s0231198

New Member
Jan 15, 2020
1
0
1
Ohio
Usually when I get that P0299 code, its time to pull the map sensor out of back side of intake and clean it, it gets gunked up pretty good. Just use the MAF sensor cleaner to clean it, takes roughly 15 mins to pull it out and clean it and reinstall everything.
 

mlgdave

New Member
Jul 30, 2020
10
2
3
Central California
Truck Year
2015
Usually when I get that P0299 code, its time to pull the map sensor out of back side of intake and clean it, it gets gunked up pretty good. Just use the MAF sensor cleaner to clean it, takes roughly 15 mins to pull it out and clean it and reinstall everything.
Will give it a go. Tyvm. Gonna also just bite the bullet and get the HD delete
 

mlgdave

New Member
Jul 30, 2020
10
2
3
Central California
Truck Year
2015
Cleaned the MAP sensor and EGR valve, didnt have a way to clear the code. It didnt improve the performance. I CAN get to 77 MPH on freeway (but you can tell the turbo isnt spooling up)

Will I cause permanent damage to drive it without the turbo spooling?

It sucks on hills but does get to 77 MPH like i said

Dave
 

TMayor

New Member
Jul 25, 2020
7
0
1
ohio
Truck Year
2016
I am having the same problem with Mine 2016 94xxx miles I bought it about 10 months ago. It was in the shop 4 times in the first two months with the po299 code. its been 7 or 8 months and having the same issue again. I replaced the map sensor and cleaned out the tube which wasn't that Dirty cleared the codes only to come back up within a mile. It sounds like this is a common issue what does it take to fix it.
I have read that alot of folks get the GDE Tune does that clear it up. It sounds like a few of you this GDE is a joke. So what are my options?
 

mlgdave

New Member
Jul 30, 2020
10
2
3
Central California
Truck Year
2015
Cleaned MAP sensor and EGR valve. Put back together code still showed. Went to walmart, bought a $39 code reader, erased code and it has stayed off so far. Will see how many miles I get before (if) it comes back on! :)

Dave
 

LandonLopez17

New Member
Aug 3, 2020
2
0
1
Ontario, Canada
Truck Year
2015
I have had the SERVICE ELECTRIONIC THROTTLE CONTROL on going for about 9 months now. Originally would come on every few hundred kms and vanish when I shut the vehicle off. It has since become more consistent and I can not go more than 30km (if im lucky) on the highway without the SETC light coming on and losing power. Truck averages about 100 km/h on flat ground, but fluctuates about 20 km/h in either direction depending on the grade. Can usually drive city speeds for a long time without any issues. I have had it in to a local mechanic early into all of this and the code cleared before any repair was suggested. Now ive had a $550 diagnosis from the dealership to "replace exhaust temp sensor to start" and im not sure its worth following through. Truck showed codes "P0546" and "P2BA9"