• Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

...Well, not the battery

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
I posted my battery story earlier, and thought things were good, but they are not. Since a lot of you read that and while you may/or may not have found it amusing, the saga continues and I thought I'd better post a new thread so some of you might look again. Here's the latest. Any input is very welcome. THANKS
===========================
Well, it was a nice story with the battery......but it seems it hasn't ended there!

Yesterday morning, got into the truck, started it up and all was good, it seemed.

Drove for an hour and stopped for lunch. Came out 90 mins later.....SAME NO START PROBLEM!:unsure:

We waited for about 10 mins. and tried again....started right up without any indication of a problem. Just like before the battery was swapped out.

Went to a local Dallas dealer and after telling them the symptoms they check for a code and there were none. They said they couldn't get on it today, but if we wanted to we could come back next Wed. and their diesel mechanic might have time to look at it.

Obviously we need to get back home and not real comfortable with not having any idea of what the problem might be AND if it was going to get worse. Facing East Texas with a failed truck was not my idea of a fun time with the wife and two dogs.

Went to a second dealer. After much chit/chat in the service center, was told they could get on it Monday or Tuesday, but have to leave the truck now or not be in the queue until maybe a week. Left the truck and found a ride back to the campground.....an hour away.

I have the MoPar MAXI insurance for 100K and 93K on the truck. Not sure if that will do any good, but at least something might pop up.

Symptoms:
1 Truck may or may not start at any give time.
2. Engine hot or cold was not a defining state
3. When it failed to start, each time, it acted like it was going to, more than a solenoid click and "about maybe a revolution or two.
4. Would do NOTHING if attempted immedicably following the failure ....not dash lights/media screen/ nothing just like a totally dead battery.
5. After anywhere from 15-20 sec., truck would start up like nothing was wrong.
6.. When running, all the temps and gauges, and indicators on the readouts showed normal as they have for the past 5 years.
7. Only one things did change before the battery replacement and that was the voltage readout changed from 14 to 13v. This is why we thought it might be battery related and with a 7 year old battery....well certainly a place to look first.
8. After the battery replacement...NOTE: the voltage readout REMAINED at the 13v level...not down or up and no change with A/C, radio, lights , etc.

Any ideas??
 

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
Interesting:
Just got a text from the dealership.
Bad starter and probably caused by a going bad tone wheel.
They said due to the tone wheel potential issue probally has caused long start times and thus the starter going out.

Really interesting:
The truck, for the past 4.5 years has always started up fast, like first turn-over of engine. Never had any long cranks
 

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
Just got word from the dealer. No parts available for at least a week. We are stuck in Texas till something gives!

Not good. May have to fly the wife home and sit here with the two dogs for the next week, at least. Then drive home for two days by myself. YUCK!
 

EcoLeesiel

Member
Oct 2, 2018
86
60
Truck Year
2015
Feel your pain my man. Similar issue....no start...no codes....2 weeks down waiting for parts!!! Tone Wheel and sensor just replaced under FCA warranty recall. Luckily my local Dodge mechanic had already been through this scenario with a few Eco's and sure enough the tone ring magnet material was just startiing to crumble off. All good now and grateful for a legit diesel mechanic in my small town.
 

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
Good news, I hope.
Dealership called and said they found the part and are overnighting it. At best should be here tomorrow or Thursday at worst. IF early enough on Thursday I might get it back on Friday! Lets cross our fingers!!🤔
 

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
Well, they finally got the part and we received an update today.
Truck not ready...neither today nor tomorrow, but anticipate maybe Monday will be ready to go. Good news is that they are replacing the starter, tone ring problem along with replacing the EGR, air bag sensor and all the other outstanding recall items.

Obviously they can't do the HPFP replacement yet, but I should be in pretty good shape to get back to Charleston, SC come Tuesday.....provided they put all the bolts back tight!

Stayed "tuned" for more to come!
 

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
Here I sit, all broken hearted, my truck has failed and I just ......!

Well, Monday came and went but no truck. Late yesterday they did respond indicating that it would certainly be done today by 5pm.

Only time will tell.:confused:
 

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
I have my truck back!! Yea!!!!!
New Starter
New EGR valve
New Tone Ring

While it took longer than I would have hoped (we always want things yesterday don't we). The work was done and all seems well. The service rep was spot on in getting the info to the mechanic; the mechanic listened to the report about the starter issues and immediately seemed to know there was a tone ring issue. Sure enough, see attached pic. Mechanic was right on the money.
I hope this forum doesn't delete this info, but the dealership is Shottenkirk Dodge/RAM/JEEP in Denton, TX. The excellent service advisor: Hunter Ingram.
When good service is given it should be well documented and noted. If your in the Dallas/Denton area, you should certainly frequent these people.
 

Attachments

  • tone ring.jpg
    tone ring.jpg
    190.5 KB · Views: 12

1shadowsabre

Well-Known Member
Oct 18, 2015
711
256
Truck Year
2015
Congratulations on getting your truck fixed a long way from home!
I also think you seemed to keep a pretty attitude along the way and I would wager that contributed to the good service you got!
 

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
Looks like the truck is running great. Just staying in town today before I trust hitting the road back to Charleston with the TT.
I'm going to start a new thread with another question about now having 13V instead of 14v constantly showing on the dash display. Not sure why.
 

Frank246

Member
Feb 20, 2019
79
26
Truck Year
2015
Made it back home without issue. Runs great and the only problem is that the new starter is so quiet, I can hardly tell if the engine started without opening the truck door. Strange, but nice!
 
Top