• Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

2016 laramie ecodiesel cranks wont start

anthvodvarka

New Member
Nov 22, 2021
3
0
Truck Year
2016
i have a 2016 laramie ecodiesel , it has 128k on it . today i drove home got dressed head back out to go to a friends and as i was turning onto the highway i sped up and then the truck just shut off ! i coasted to the side of the highway on the on ramp , and the screen said low oil pressure, so i got out of the truck check the dip stick and its at max, i then said okay to myself wait for it to cool down and the air bag suspension will level out the truck and then re check it, so i did that. waited an hour . got out recheck and it was at max. so i went back to the truck push the button to start and added pressure to the break pedal and hit the start button and it just cranked and cranked. no start up , so called a tow truck got it back to the house and i tried again at the house and this time the engine kept cranking as i let off the button and break pedal.
i have no clue what would cause the low oil pressure to come on and also for a quick second while driving something flashed saying something about the air suspension or something before turning off.
but the truck lights radio and all that comes on when you push the start button but doesnt start when you apply the break and hit start just cranks! can anyone help me out
 

Tremper126

Moderator
Staff member
Supporting Member
Feb 15, 2019
708
272
Truck Year
2014
Sounds like your tone ring failed. The oil pressure light came on because the truck failed to continue running and it detected no oil pressure when it should have been (engine off but was running before). Can you hear your intank fuel pump run if you leave your foot off the brake and push the start button?
 

anthvodvarka

New Member
Nov 22, 2021
3
0
Truck Year
2016
Sounds like your tone ring failed. The oil pressure light came on because the truck failed to continue running and it detected no oil pressure when it should have been (engine off but was running before). Can you hear your intank fuel pump run if you leave your foot off the brake and push the start button?
Yes I can hear it .
 

Ninni

New Member
Nov 24, 2021
2
0
Truck Year
2016
Hi there, 2016 Longhorn, same thing happened to me today on the hwy, any idea if that tone ring is something that can be done in your own garage?
Thanks
 

Ninni

New Member
Nov 24, 2021
2
0
Truck Year
2016
Thanks, I feel comfortable to do that but in this case I make more than I save by bringing it to a shop.
I was wondering if anyone had gone through the same situation and got it fixed.
 

GearHead

Active Member
Sep 13, 2016
304
103
Truck Year
2014
Thanks, I feel comfortable to do that but in this case I make more than I save by bringing it to a shop.
I was wondering if anyone had gone through the same situation and got it fixed.
Yep. Fixed at dealer. All covered under AEM warranty except the ring itself, cost me $11.43. I no longer feel comfortable dropping a transmission with transfer case, not that young anymore, hernia surgery, shoulder surgery, total knee replacement.
 

anthvodvarka

New Member
Nov 22, 2021
3
0
Truck Year
2016
Thank you guys , I'm bringing it in to the shop today, and I'll let you know if it was the tone ring
 
Top