ecodiesel problems

  • Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!
  1. L

    Service Electronic Throttle Control

    I have had the SERVICE ELECTRIONIC THROTTLE CONTROL on going for about 9 months now on my 2015 ecodiesel with 180,000kms. Originally would come on every few hundred kms and vanish when I shut the vehicle off. It has since become more consistent and I can not go more than 30km (if im lucky) on...
  2. R

    2015 Ecodiesel owner. Blew engine last night 74495 miles

    As the title states I am a 2015 Ecodiesel owner who had their engine blow at 74495 miles last evening. It happened when I dropped a gear to have more power for a hill I was climbing. No warning lights and no previous problems or oddities. The engine started knocking loudly and power was lossed...
  3. D

    #ECODIESEL #SCANDAL

  4. M

    DPF filter full - see dealer

    Was doing a small errand tonight getting ready for a road trip tomorrow. Drove about a mile to my "toy shed" and saw a message "Need Regerneration - drive at Highway speeds..." Shut down to unload a few things from the back bed, then restarted the engine. Now get a message "Exhaust Filter 100%...
  5. K

    Electronic Throttle Control Error - Dealer says its fuel injectors

    2015 Ram 1500 with 32,000 miles. This is the third time I have received the message and had the engine go into limp mode. The first time the truck was 2 months old, it was 30 degrees out and I had parked it for about an hour. The dealer had it for 2 days and all they did was a software update...