• Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Automatic transmission fluid check

Rsmouse

New Member
Feb 6, 2021
2
0
Truck Year
2015
I have a 2015 Ram Tradesman with 3.0 eco Diesel engine. on three separate occasions approximately 2-3 weeks apart, my transmission has refused to engage. Engine is running, everything worked great, pulled into driveway, turned gear selector nob to Park, left engine running for several min. Got back in to move truck, turned gear selector nob to reverse and nothing happens. It acts as if it’s still in Park. I can rev the engine but nothing changes. If I try moving selector between drive and park or drive and reverse, on one occasion it engaged.
on second occasion I had to turn off engine, then restart and it engaged. The third time I used the 4wd controls to get it to engage.
has anyone else experienced similar problems?
if so, what did you do to correct it?

2nd, how do I check transmission fluid? there is no tube with a dip stick
 

1shadowsabre

Active Member
Oct 18, 2015
573
196
Truck Year
2015
With the truck level I believe you have to pull the fill plug on the transmission pan much like a differential. The fluid should be even with the bottom of the fill hole.
 

Rsmouse

New Member
Feb 6, 2021
2
0
Truck Year
2015
Thanks, I’ll do that.
if it’s low, is that also the opening where I would put in more?
 
Top