• Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Cold start oil pressure

jomac0321

New Member
Jul 10, 2023
4
2
Truck Year
2015
2015 Ram eco diesel. The past 2 days I’ve went to start my truck for work it wouldn’t build oil pressure until shutoff and restarted after that it immediately builds and is great the rest of the day. Yesterday I immediately shut it off and restarted it but today I gave it a second thinking it may just need a second where it’s coldish (mid 20s) but it never built and I got a low oil pressure shit off message but as soon as I restarted everything was great. Has anyone dealt with this before? I’m leaning towards the switch or an oil cooler issue maybe a check valve in it? TIA
 

rodd

Member
Mar 19, 2022
32
3
Truck Year
2017
Probably a switch or sensor because after you restart it it comes alive. There is an oil pressure sensor just below the oil filter housing. Not sure if there are other oil sensors but Check the wires and connector first then check the sensor. Not sure what the readings should be on the sensor though.
 

TC Diesel

Well-Known Member
Jul 14, 2016
2,469
700
Truck Year
2015
The VM 3.0 has oil Switch, the Oil temperature sensor is live.
ED oil Gage1.jpg
ED oil gage psi2.jpg
 

Dream Big

Member
Feb 1, 2017
38
19
Truck Year
2015
2015 Ram eco diesel. The past 2 days I’ve went to start my truck for work it wouldn’t build oil pressure until shutoff and restarted after that it immediately builds and is great the rest of the day. Yesterday I immediately shut it off and restarted it but today I gave it a second thinking it may just need a second where it’s coldish (mid 20s) but it never built and I got a low oil pressure shit off message but as soon as I restarted everything was great. Has anyone dealt with this before? I’m leaning towards the switch or an oil cooler issue maybe a check valve in it? TIA
Might consider doing what I did. If the oil pickup tube is sludged and there is muck at the bottom of the oil pan, it could cause pressure issues, in my humble opinion. So far, my truck has had no issues with pressure since I did a thorough cleaning of mentioned parts. Don’t want to starve the pump.
 

jcbanks34

New Member
Aug 3, 2022
4
13
Truck Year
2015
2015 Ram eco diesel. The past 2 days I’ve went to start my truck for work it wouldn’t build oil pressure until shutoff and restarted after that it immediately builds and is great the rest of the day. Yesterday I immediately shut it off and restarted it but today I gave it a second thinking it may just need a second where it’s coldish (mid 20s) but it never built and I got a low oil pressure shit off message but as soon as I restarted everything was great. Has anyone dealt with this before? I’m leaning towards the switch or an oil cooler issue maybe a check valve in it? TIA
This is exactly what my 2015 did for about 2 weeks and then my engine blew up!! I would get it in ASAP!!
 
Top