• Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Message...."Service Electronic Throttle Control"....No codes & SFT

KnowFear

New Member
Nov 28, 2019
15
4
Truck Year
2016
So this happened this week...

Last friday I started the truck and was leaving the parking lot when all of a sudden the message center said "Service electronic Throttle Control". It seemed to be running fine and I was able to get home. I scanned the computer with my Autel MaxiCOM tablet scanner and found no hidden codes present. So with nothing to erase I went to my service menu and did a recalibration of the throttle valve. Message still there.... so I decided to try and drive it again. It started fine but when I tried to drive it was in limp mode and couldn't get over 40 along with shuddering under load and the intake sounded like a pressure cooker as it was sucking the air into the engine.🤔 Stumped and under warranty I took it to the dealership. They "reprogrammed" it to fix it Monday saying it was an old program. I went to pick it up at the end of the day and it was shuddering WAY worse under load. It eventually went away by the end of the day. I noticed too that my MPG went from 22 to 17!! WAY TO RICH! The next morning I started driving it and once again before I left the neighborhood the "Service Electronic Throttle Control" message. So back to the dealership it went and they paid for the tow this time since it was the same issue unresolved.

They called me this afternoon to talk to me about the emissions being turned off. I told them that I put a SFT Tune on it because there is no fix insight for the EGR issues that these trucks have and I'm not about to have a $30k truck go up in smoke or continually break due to the excessive soot. They responded by saying that they believe that my problem is the SFT tune, but they are going to have another higher up tech check it out for a wiring issue. I told them that there have been no other documented cases supporting their belief so I don't feel that they can prove it, but they might just have to flash it back to the stock tune to see if that cures the problem. They are trying to work with me on it, but the top dogs in the Chrysler tech are no longer willing to help them because I put the SFT Tune on the truck.
 

rcupps

New Member
Jan 2, 2020
19
5
Truck Year
2016
I get that message when I power Jack to stop the Turbo Lag. It's that computer controlled no cable throttle. Just my opinion.
 

KnowFear

New Member
Nov 28, 2019
15
4
Truck Year
2016
That's what I think too, but since there are no MIL codes they want it back to the stock tune before going further to diagnose. Why would my tune all of a sudden be a problem after working perfectly for 3 weeks. :unsure: I don't think so, but whatever. I'm going to flash it again and see what happens.
 

silvoeac

New Member
Jan 29, 2020
2
0
Truck Year
2015
I just had the same issue today with my 2015 Ecodiesel with 86000 miles, I took my truck to the dealer Planet Dodge in Miami the Services guy char me $270.00 just to assess the issue, they said that the warranty I have doesn't cover this problem. I ended leaving my truck in the dealer, renting a car with my money and the guy with no helping face said that maybe tomorrow the mechanic can check my truck. I'm a RAM lover but I think its time to go the gas Hemi and forget about ECOProblems. I will appreciate any help or recommendations.
 

KnowFear

New Member
Nov 28, 2019
15
4
Truck Year
2016
Was the check engine light on or just the message in the information? If this is the case and you have a scanner all you need to do is clear codes, start the truck and it will be gone so that you can drive it.

This is a documented problem for the 2015 and 2016 EcoDiesel.
 

silvoeac

New Member
Jan 29, 2020
2
0
Truck Year
2015
Was the check engine light on or just the message in the information? If this is the case and you have a scanner all you need to do is clear codes, start the truck and it will be gone so that you can drive it.

This is a documented problem for the 2015 and 2016 EcoDiesel.

Yes, the engine light is on. Can't do anything the car is in the dealer.
Thank you, I will update you guys today.
 

Travisclark

New Member
Feb 27, 2021
2
0
Truck Year
2015
My egr cooler blew so i did a delete and tune. Same thing service etc with no codes. Did you ever figure what was wrong
 

CBSnook

New Member
Apr 6, 2021
24
1
Truck Year
2016
mine is tuned and wont start and says this have a code reader coming in the mail tomorrow to see if i can get farther
 
Top