• Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Programming Accelerator Pedal

LGSteggy

New Member
May 31, 2022
1
0
Truck Year
2015
I have a 2015 that has been deleted been running great for 2 years since delete. Got an ETC message a couple of days ago. It was throwing codes P0198 & U1424. Cleaned the MAF sensor but didn't fix it so I went ahead and replaced the MAF sensor & Oil pressure sensors. Still having issues so I'm replacing the Accelerator Pedal. Its an easy swap but I can't seem to get the new accelerator pedal to sync with the truck. I have tried putting it to run and holding the accelerator down for 15 seconds & beyond, turning it off then starting it but to no avail. I have also tried disconnecting the battery for a bit. Does anyone have any ideas on how to get this to sync up to the truck? Thanks
 

Attachments

  • scs truck.jpg
    scs truck.jpg
    111.6 KB · Views: 2

GearHead

Active Member
Sep 13, 2016
327
114
Truck Year
2014
AlfaOBDII, relearn parameters for new pedal module. The measures you have taken will be insufficient to achieve what you need to do. Since you have a deleted truck it may pay to have the AlfaOBD scanner at the ready for future use.

Good Luck.
 
Top