ABS Light with Remote Start, Cruise doesn't work

  • Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Joe vela

New Member
Nov 20, 2015
6
2
3
Has anyone had trouble with ABS an engine lights coming on and when it does remote start, cruise won't work we have made 2 trips to the dealer
 
  • Like
Reactions: BoostN

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,745
958
113
Tennessee
ecodieselram.com
Truck Year
Not Listed
Has anyone had trouble with ABS an engine lights coming on and when it does remote start, cruise won't work we have made 2 trips to the dealer
I've not seen any mention of that Joe.
Welcome to the site, hopefully someone can chime in that has any info. Let us know how you dealer visit goes!
 

jdn112011

Well-Known Member
Oct 18, 2015
1,202
310
83
27
Roseau, MN
Truck Year
2015
I have no idea what is causing the ABS malfunction but that light being on is what is prevention cruise control.

Air suspension, ABS, esc, so on and so forth; anything regarding the suspension o braking system that puts on a EVIC message and your cruise control will not operate.

I had a little trouble with my air suspension (playing with it too much) and had a similar issue with cruise.
 

jdn112011

Well-Known Member
Oct 18, 2015
1,202
310
83
27
Roseau, MN
Truck Year
2015
I guess get the dealer to check out the ABS sensors and wheel speed sensors. Something happened
 

Joe vela

New Member
Nov 20, 2015
6
2
3
Well got my truck bk they said it was the speed sensor but his expression showed like he was not sure
 

jdn112011

Well-Known Member
Oct 18, 2015
1,202
310
83
27
Roseau, MN
Truck Year
2015
Theoretically that should be it. Maybe damage to the wiring for it was allowing moisture to throw it off
 
  • Like
Reactions: Joe vela

Mharrison

Active Member
Jun 17, 2015
373
105
43
Yuba city, ca
Truck Year
2015
Have you taken a look at BoostN post of the latest recall for the rear axle it states contact your dealer immediately if your abs light comes on.
 
  • Like
Reactions: Joe vela

jdn112011

Well-Known Member
Oct 18, 2015
1,202
310
83
27
Roseau, MN
Truck Year
2015
I don't know about that being a complete failure. I'd think if ABS light came on it'd be wayyy too late. And he seemed to have a reoccurring issue whenever moisture was present. But we haven't gotten an update so who knows..?
 

Mharrison

Active Member
Jun 17, 2015
373
105
43
Yuba city, ca
Truck Year
2015
I figured it may be worth mentioning. It's not very often we see moisture related electrical issues anymore with all of the weatherpac connectors etc. Not saying it's not possible but with our conditions might have been more coincidence than cause.
 

jdn112011

Well-Known Member
Oct 18, 2015
1,202
310
83
27
Roseau, MN
Truck Year
2015
That's why I referenced a possible damaged wiring section or similar in the beginning. I understand there's a lot more preventative measures towards water resistance on wiring but there's still things that could happen; i.e. over torquing the wheel sensor or misaligned sensor during the installation cracking the housing, or damaged wiring.
 
  • Like
Reactions: Joe vela

jdn112011

Well-Known Member
Oct 18, 2015
1,202
310
83
27
Roseau, MN
Truck Year
2015
But you're right in that situation a dealer should be more than sure especially during R&I when they find damage so who knows really without the physical hands on and in your face diagnosis
 
  • Like
Reactions: Mharrison

Mharrison

Active Member
Jun 17, 2015
373
105
43
Yuba city, ca
Truck Year
2015
There is no doubt....the modern wire insulation is garbage we have replaced several harness on our tractors due the the loom wearing right through the wires. Speed sensors anymore though are typically on the transmission.
 

jdn112011

Well-Known Member
Oct 18, 2015
1,202
310
83
27
Roseau, MN
Truck Year
2015
He means the wheel speed sensor for ABS/ESC/TC not referencing it as the actual speedometer sensor
 
  • Like
Reactions: Mharrison