Low cabin heat/even less at highway speeds

  • Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Rob Adams

New Member
Nov 1, 2017
1
0
1
Truck Year
2014
Hi Guys,
I am hoping someone can help, I’ve got a 2014 outdoorsman and have been having cabin heat issues for the last 6 months.
It takes a very long time for my truck to throw any cabin heat and even when it does it’s not very hot. My father in law has the same truck and blows much hotter. When I’m on the highway it blows even less hot air, doesn’t matter if it’s on defrost or through the vents. My coolant temp is correct, heater core hoses are hot, I am assuming it’s a hvac issue. I live in Alberta and can’t take another cold winter!! Haha
 

Zachary

Member
Oct 22, 2017
43
17
8
Truck Year
2014
It may be a malfunctioning 3 way coolant valve or thermostat.


Sent from my SM-G900V using Tapatalk
 
Last edited:

Dmorlino

New Member
Dec 20, 2017
1
0
1
Truck Year
2015
Rob,
Did you ever find a solution to this problem? I have been experiencing similar issues and what little I can find does not give a consistent cause or solution. Thanks in advance?
Deny
 

Wesley Lantz

New Member
Apr 7, 2018
13
2
3
Truck Year
2015
Check your coolant. I have the same issue when the coolant is low. coolant is leaking in the egr cooler