• Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

PCM Code P050E

ShanePi

New Member
Sep 1, 2019
9
4
Truck Year
2018
Hello all, am new member with 2018 Ram ecodiesel. Code is cold start exhaust temp to low. Even at 80deg. They replaced exhaust sensor, light on again after a week. Then they replaced PCM and checked harness. Light on again. Same code. Then they installed data retrieval box in OBD port. Waiting near 2 weeks to hear back from FCA tech support. Dealer can do nothing more. No other performance issues. Anyone have similar issues? Thanks.
 

John

Well-Known Member
Nov 13, 2015
1,186
380
Ask your dealer if they performed the “Flash ECM Per TSB1803018”
 

ShanePi

New Member
Sep 1, 2019
9
4
Truck Year
2018
When they installed new pcm they it's all up to date. That's when they installed data box to record fault when it occurred. FCA has it now.
 

carlhenry

Well-Known Member
Nov 21, 2018
1,506
279
Truck Year
Not Listed
Welcome to the group I have a 2018 tuned it before any codes had a chance never had a problem YET
 

ShanePi

New Member
Sep 1, 2019
9
4
Truck Year
2018
Update to my P050E code. Recently noticed coolant loss in recovery tank. Had it at dealer. They pressured tested found no leak and topped it up. 2 weeks later low again. This truck under Warranty. Removed diffuser tube myself and boost sensor and all wet. Told dealer and egr cooler leaking after all. They replaced it. They reset check eng light. Been 2weeks so far no code.
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
4,167
1,102
Truck Year
Not Listed
Update to my P050E code. Recently noticed coolant loss in recovery tank. Had it at dealer. They pressured tested found no leak and topped it up. 2 weeks later low again. This truck under Warranty. Removed diffuser tube myself and boost sensor and all wet. Told dealer and egr cooler leaking after all. They replaced it. They reset check eng light. Been 2weeks so far no code.

Glad they took care of it for you. Saved some money for sure.
 

ShanePi

New Member
Sep 1, 2019
9
4
Truck Year
2018
Makes me think coolant going down exhaust and misting temp. Sensor.
 

Midnight32

New Member
Nov 22, 2019
16
1
Truck Year
2016
Currently going through this same issue, truck back in the shop for cold start (2nd time in a week). Same exact symptoms.
Also dealer mentioned the recall today. Told me about egr and mentioned the water pump might be up for replacement as well.
 

Tremper126

Moderator
Staff member
Feb 15, 2019
842
309
Truck Year
2014
I’m not sure why your wp would be bad also but who knows. Dealer throws parts until it’s fixed 😂
 

ShanePi

New Member
Sep 1, 2019
9
4
Truck Year
2018
So after egr cooler was replaced, a week later P050E code again appeared. Was able to get info regarding wiring harness to the temperature sensor related to this code. Unplugged a harness plug on passenger side in engine and applied electrical insulating compound to the female side and re plugged in. About 5 drive cycles later light went out. Been about 8wks and nothing. Truck just turned 24K. So much for dealer telling me checked harness and all ok. Don't no for a certainty that this fixed it. But could be a harness pin issue.
 
Top