"Service Electronic Throttle Control"

  • Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

Trenton

New Member
Oct 31, 2017
2
0
1
Truck Year
2015
I purchased my 2015 Lonestar EcoDiesel used with 61k miles and after having it for 1 week, I drove it about 165 miles down to the ranch for the weekend. Everything was fine driving down there, even impressed with managing 30mpg at 80mph! When I got to the ranch, it started taking 2-3 cranks before it would start up. When it came time to head back home, I stopped to fill up the tank a couple of miles down the road. Again, 3 tries before it finally started and as soon as I pulled out the "Service ETC" alert came on and I realized it was in limp mode and would not go over 38mph. I looked online and found this page and read several stories about this happening, and what it sounded like, to me, was a computer malfunction. I crawled it to the nearest O'Reillys and had them clear the ETC alert and it was fine from there. Very unsettling that this could happen at any time! I plan on reporting it to RAM.

Truck also pulls to the left. When I bought the truck, the were putting 2 new tires on it, even though the tires didn't seem to be very worn - I was ok with the new tires! the air pressure was even across all 4 tires when I got it.

I have noticed that when the fuel is low is when I am having trouble getting it to start on the first try, even though the range says as many as 84 miles left. I guess that's cutting it too close for a diesel.

One last thing that has me totally baffled...the remote start will start the truck, and sometimes, the truck will shut back off after maybe 10-15 seconds. This happens with a full tank...

This is my first RAM and I'm not very excited about my purchase anymore.
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,250
800
113
Tennessee
www.ecodieselram.com
Truck Year
Not Listed
Welcome! Hard cranking, injectors maybe? Time to use that warranty and see what the dealer has to say. ETC is pretty popular around here unfortunately.
 

Trenton

New Member
Oct 31, 2017
2
0
1
Truck Year
2015
Well at 62k miles, this truck is just passed the warranty coverage. Sounds like I need to go buy an extended warranty before I really need it!
 

kracer00

New Member
Nov 14, 2017
2
2
3
Truck Year
2016
I am also having the ETC error and scheduled for the shop 2nd time for me engine light also comes on. first time 12,000 mi done some update flashing and a manual regeneration on the DEF. 40 K and i about got hit in a intersection when it did not go and ETC on and engine light. Went to the dealer i purchased it from today and they could not get me in today but asked if they could at least clear the code. (all booked up and no techs available) Stopped in at the parts store and the codes would not clear. So i tried the unhook the battery for about 30 min. and that did not work either.
Closest dealer did not even have oil for an oil change. (they will never see my truck again) Left the hood up sitting outside.
Do not get me wrong i love diesels and been driving them for 18 years but going to the dealer 1.5 hrs away that i trust is a pain and the 1st time it was an all day affair. This was my first new truck and it cost more than my house originally.
Yes after reading all the troubles it really makes me wonder but at least i have warranty to 100k.
Truck goes in the 30th i did not want to trust a Thanksgiving rush job. :)
I will pay more attention and ask some questions and let everyone know what my problem was.
 
  • Like
Reactions: BoostN

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,250
800
113
Tennessee
www.ecodieselram.com
Truck Year
Not Listed
I am also having the ETC error and scheduled for the shop 2nd time for me engine light also comes on. first time 12,000 mi done some update flashing and a manual regeneration on the DEF. 40 K and i about got hit in a intersection when it did not go and ETC on and engine light. Went to the dealer i purchased it from today and they could not get me in today but asked if they could at least clear the code. (all booked up and no techs available) Stopped in at the parts store and the codes would not clear. So i tried the unhook the battery for about 30 min. and that did not work either.
Closest dealer did not even have oil for an oil change. (they will never see my truck again) Left the hood up sitting outside.
Do not get me wrong i love diesels and been driving them for 18 years but going to the dealer 1.5 hrs away that i trust is a pain and the 1st time it was an all day affair. This was my first new truck and it cost more than my house originally.
Yes after reading all the troubles it really makes me wonder but at least i have warranty to 100k.
Truck goes in the 30th i did not want to trust a Thanksgiving rush job. :)
I will pay more attention and ask some questions and let everyone know what my problem was.
Welcome, keep us updated. The more we learn the more it helps everyone else.
 

GearHead

Active Member
Sep 13, 2016
174
63
28
Truck Year
2014
I bought my 2014 used, 20K miles, and I did my normal fuel system service and got the ETC right after filling up, limped home and scanned truck with my home scanner finding no abnormalities, reset and still found no abnormalities. Just a couple of months later another fuel system service and just filled up and the ETC, had scanner in truck, did roadside diagnosis found nothing, continued on my way. About four months later my wife experienced the ETC, right after fill up, and once again I found nothing. Checked fuel pressure, diagnosis electronics, checked voltages system wide. Have not had another occurrence. I can not speak to all others but mine has become an overly sensitive system, but several fuel filter changes and oil changes, fuel system services may have corrected some dirty injector issues because I haven't had the code for quite sometime. I now have 57K miles on the truck. I have noticed an improvement to throttle response and engine noise as time and services compile. I have considered a faulty Throttle Position Sensor but if it does not fluctuate while I have my scanner installed I cannot prove or disprove fault. I could just change both Throttle Position Sensors and see what happens, but not inclined. Another thing I utilize is Dielectric Silicone Grease on all electrical connections.

Sometimes buying used you have to correct someone else's lack of maintenance to get everything back in order. We just bought a 2015 JEEP Grand Cherokee with ED and the first thing I did was perform a fuel system service with the very first fill up.

Trenton would do well to find a qualified diesel mechanic that can appreciate the Common Rail High Pressure system used by this engine and he may end up with new injectors if they cannot be cleaned by system services. Good Luck my truck has been great.

I hope everyone experiencing difficulties can find a agreeable solution.
 

Earl

New Member
Jan 19, 2018
4
2
3
Truck Year
2017
I started my new eco diesel this morning at -28 C. Plugged in for about 2 hours before starting. Service ETC warning came on and now the red warning light and check engine lights are on. Very little power. Going to call the dealer in the morning to get this fixed. 2230 kms on it. Less than 3 weeks old. I live just outside Edmonton. I may regret buying this truck if this is the norm...
 

Oconomowoc

New Member
Jan 22, 2018
11
0
1
Truck Year
2017
I started my new eco diesel this morning at -28 C. Plugged in for about 2 hours before starting. Service ETC warning came on and now the red warning light and check engine lights are on. Very little power. Going to call the dealer in the morning to get this fixed. 2230 kms on it. Less than 3 weeks old. I live just outside Edmonton. I may regret buying this truck if this is the norm...
-11 here this morning. I had the engine block heater plugged in. Drove 2 blocks a got the electronic throttle service error. Sitting at dealer now. 989 miles on engine



Sent from my iPad using Tapatalk
 

DavidD

New Member
Dec 19, 2017
12
8
3
Sudbury, Ontario, Canada
Truck Year
2017
I started my new eco diesel this morning at -28 C. Plugged in for about 2 hours before starting. Service ETC warning came on and now the red warning light and check engine lights are on. Very little power. Going to call the dealer in the morning to get this fixed. 2230 kms on it. Less than 3 weeks old. I live just outside Edmonton. I may regret buying this truck if this is the norm...
I got 4300kim on mine with the same problems in cold weather, been to the dealer 4 times already. Ongoing issues, they tell me FCA needs to come up with updated software to resolve the issue. I'm in Sudbury, ON
 

tkabrick

New Member
Feb 5, 2018
3
1
3
Truck Year
2017
Not a great solution but ever since I put on the winter front I have yet to receive the service electronic throttle message and check engine light. Before I put the cover on I got the message numerous times in the first 1000 miles with the truck. Have over 6000 miles now and haven't had it happen with cold weather since
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,250
800
113
Tennessee
www.ecodieselram.com
Truck Year
Not Listed
Not a great solution but ever since I put on the winter front I have yet to receive the service electronic throttle message and check engine light. Before I put the cover on I got the message numerous times in the first 1000 miles with the truck. Have over 6000 miles now and haven't had it happen with cold weather since
How cold is your area on average? Welcome to the forum!
 

Earl

New Member
Jan 19, 2018
4
2
3
Truck Year
2017
Not a great solution but ever since I put on the winter front I have yet to receive the service electronic throttle message and check engine light. Before I put the cover on I got the message numerous times in the first 1000 miles with the truck. Have over 6000 miles now and haven't had it happen with cold weather since
 

Earl

New Member
Jan 19, 2018
4
2
3
Truck Year
2017
Good to hear. Mine has been on for 2 weeks. Still got the ETC warning.
 

tkabrick

New Member
Feb 5, 2018
3
1
3
Truck Year
2017
Live in western Wisconsin so routinely see stretches of below 0F temps. If temp is below 20 I keep two of 4 flaps closed and when it's below zero I close all 4 flaps. Seems to have fixed my issues with cold weather
 
  • Like
Reactions: BoostN

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,250
800
113
Tennessee
www.ecodieselram.com
Truck Year
Not Listed
Live in western Wisconsin so routinely see stretches of below 0F temps. If temp is below 20 I keep two of 4 flaps closed and when it's below zero I close all 4 flaps. Seems to have fixed my issues with cold weather
Do you store your truck in a garage? With that said, I wonder why some freak out, and others don't? Many reports here of the cold weather causing many issues.
 

1st Ram

New Member
Feb 6, 2018
6
1
3
Truck Year
2017
Hey Oconomowoc, What dealer is yours sitting at? Ours is at Ewald. We had picked ours up New Years day. Was in at dealer on the Jan 3 with ETC and 88 miles on odometer. They cleared it but could not get it to come back on. Temp back then was about 10 below. Yesterday morning was -11. This time it did it after driving about 5 miles. Last time it happened was on start up. First brand new vehicle we ever bought and in for service twice in its first month. I did find out, if you keep your foot down trying to get it to go faster you will go slower in limp mode. Feather the throttle and you'll get to the dealer faster. Wife is not too happy. It's her truck.
 

tkabrick

New Member
Feb 5, 2018
3
1
3
Truck Year
2017
Yes it is stored in a garage but before the winter front, didn't matter if it was in the garage or not it would throw the CEL and electronic throttle error. After sitting outside at work for a couple hours it would throw the codes. Seems others have had water drained from the intercooler after thawing it out. For me, seems like keeping the CAC temp above freezing seems to have solved my issues
 

Boondocker

New Member
Jun 14, 2017
26
7
3
Truck Year
Not Listed
I've had this happen three times. On the second occurrence, the dealer told me that I had to purchase the winter grill blanket for $130.00 and another $140.00 to install it. I told them I would install it...took about 15 minutes. From what I've read from fellow ED owners in Canada, the grill blanket doesn't help. The grill blanket is the same game the dealers play on everyone. As soon as the temps dropped to single digits, ETC warning and no boost...like clockwork. No more screwing around with the dealer, now I plug in my scan tool and read the codes to make sure it hasn't thrown any codes that indicate something is really wrong, clear it and I'm good to go. Mine throws two generic codes...P050E & P0299. FCA is very aware of the problem and is working on a software flash solution. Basically it sounds like an EGT sensor is unhappy, tells the ECU, and the ECU dumps boost (opens the waste-gate?) to protect the engine...
 

Oconomowoc

New Member
Jan 22, 2018
11
0
1
Truck Year
2017
Hey Oconomowoc, What dealer is yours sitting at? Ours is at Ewald. We had picked ours up New Years day. Was in at dealer on the Jan 3 with ETC and 88 miles on odometer. They cleared it but could not get it to come back on. Temp back then was about 10 below. Yesterday morning was -11. This time it did it after driving about 5 miles. Last time it happened was on start up. First brand new vehicle we ever bought and in for service twice in its first month. I did find out, if you keep your foot down trying to get it to go faster you will go slower in limp mode. Feather the throttle and you'll get to the dealer faster. Wife is not too happy. It's her truck.
I also was at Ewald. It took a couple of hours to “reprogram “ the fault code. When I picked it up yesterday, February 6, I saw another ecodiesel being worked on. Not sure the problem. I haven’t started it up yet this morning. I have the block heater plugged in but I am suspecting it might not be working. If I have continued problems I WILL have a wife eruption


Sent from my iPad using Tapatalk