Service Electronic Throttle Control

  • Welcome to EcoDieselRam.com We see you haven't REGISTERED yet.

    Your truck knowledge is missing!
    • Registration is FREE , all we need is your birthday and email. (We don't share ANY data with ANYONE)
    • We have tons of knowledge here for your EcoDiesel truck!
    • Post your own topics and reply to existing threads to help others out!
    • We believe in quality OVER quantity, and a family friendly place for your #EcoDiesel home!
    CLICK HERE TO REGISTER! Problems registering? Click here to contact us!

    Already registered, but need a PASSWORD RESET? CLICK HERE TO RESET YOUR PASSWORD!

EcoDiesel_2015

New Member
Jul 23, 2015
3
0
1
Truck Year
2015
I have owned a 2015 EcoDiesel Laramie for about 2 months now and have about 8600 miles on it.
I was at a friend's house and I started my 2015 EcoDiesel truck and I see a message "Service Electronic Throttle Control."
I was able to drive the truck with a top speed of about 35 MPH. I ended up leaving the my truck at my friend's house and borrowing his truck to drive home.
I called roadside assistance on Monday afternoon and they had someone tow the truck to the nearest dealership which is over 100 miles from the town I live in.

The dealership has had my truck for since and has not called me with an update, but I have called them twice to get an update. The first call was on Tuesday and I was told that they do not know what is wrong. I called back today, and was told that they have not been able to replicate the problem, but they do see in my stored messages that I have a message, "Service Electronic Throttle Control."

I have read that this can happen if someone were to press the brake and accelerator at the same time. This was not the case. I pressed the brake and started the truck.
I'm concerned now that my new truck will leave me stranded on a trip away from home.

Sorry for the venting folks, but I didn't expect that I wouldn't be able to drive my new truck home with so few miles on the truck.

Has anyone gotten an answers/fix to this, because the dealership that is working on my truck doesn't?
 

Attachments

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,744
958
113
Tennessee
ecodieselram.com
Truck Year
Not Listed
We had another member with the same problem. His went away and never came back. I'm curious to see what the the dealer tells you because this question is starting to pop up more and more.

If the dealer is not responsive try customer care. They can probably help.

Keep us updated.
 

EcoDiesel_2015

New Member
Jul 23, 2015
3
0
1
Truck Year
2015
So, I picked up my ecoDiesel yesterday and the dealership did not know what was wrong. They said they could not recreate the problem. The reset the error message and sent me on my way.
The dealership notes are...
U1424-00 (active). P0299-00 (pending). Clear faults, run in shop, multiple test drives, harness "wiggle" tests, unable to duplicate power loss or fault condition. Database search, no applicable cases. Need to have more drive time or reschedule when acting up.

I have put on about 150 miles since and have had no problems with the truck.
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,744
958
113
Tennessee
ecodieselram.com
Truck Year
Not Listed
So, I picked up my ecoDiesel yesterday and the dealership did not know what was wrong. They said they could not recreate the problem. The reset the error message and sent me on my way.
The dealership notes are...
U1424-00 (active). P0299-00 (pending). Clear faults, run in shop, multiple test drives, harness "wiggle" tests, unable to duplicate power loss or fault condition. Database search, no applicable cases. Need to have more drive time or reschedule when acting up.

I have put on about 150 miles since and have had no problems with the truck.
Very similar stories as others. Hopefully its just a glitch and it won't return.
 

bill-e

Member
May 2, 2015
62
29
18
Truck Year
2015
I had the same issue....out of the blue. Limited me to 35mph. Then threw a code having something to do with Turbo intake temp (engine was not hot). I reset the codes, waited 10 min and restarted. Codes were gone and truck back to normal. Weird.
 

Mntntom

New Member
Jul 19, 2015
1
0
1
Truck Year
2015
I had the same issue....out of the blue. Limited me to 35mph. Then threw a code having something to do with Turbo intake temp (engine was not hot). I reset the codes, waited 10 min and restarted. Codes were gone and truck back to normal. Weird.
What devise did you use to reset the codes. I've been told a reader/scaner is not yet available for the ED?
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,744
958
113
Tennessee
ecodieselram.com
Truck Year
Not Listed
What devise did you use to reset the codes. I've been told a reader/scaner is not yet available for the ED?
Basic OBD II scanner should reset codes with no problems.

The Edge CTS monitor has that capability as well.

Welcome to the forum @Mntntom
 

seiko

Active Member
Jul 23, 2015
263
55
28
Canada
Truck Year
2015
When playing with REGEN while in stop and in Drive, I was able to see that Throttle error appear, when I had the brake peddle pressed hard and was reeving up the engine to 2000 rpm, but went away immediately when I stopped. Since then, Never tried that again.

The truck handles the REGEN on it own very well, so far. When I stop and the TEMP is 1000f, then I let it idle until it drops to 900 or less. I have the CTS 2 and ODB2 wifi unit. Still testing it, to see if I can replace the Edge with it. The only negative I seen so far, when your iphone is connected to the WIFI ODB2, you loose internet, so that Apple Maps won't load. My understanding, this may be fixed with IO9.
 

EcoDiesel_2015

New Member
Jul 23, 2015
3
0
1
Truck Year
2015
So, I just wanted to give everyone an update.
I have not had the problem return and I have put on 10,000 miles since this incident.
The truck has been running great since I originally posted.
 

Attachments

Bobby D. from TN

New Member
Nov 3, 2015
3
0
1
I just posted a note regarding the Engine Warning Light. How does one determine the codes? Am I missing something? Your 35 MPH sounds like a problem I recently had. My dealer, in a recent visit, did a "reset". I don't know what that means, but if it is something I can do, I'd like to know about it. Thanks.
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,744
958
113
Tennessee
ecodieselram.com
Truck Year
Not Listed
I just posted a note regarding the Engine Warning Light. How does one determine the codes? Am I missing something? Your 35 MPH sounds like a problem I recently had. My dealer, in a recent visit, did a "reset". I don't know what that means, but if it is something I can do, I'd like to know about it. Thanks.
An OBD coder reader is required to view the codes. Autozone and other auto stores usually will read then for free and let you know what the code is.

When they reset, they are just clearing the trouble codes in the engine computer.
 

Ofishl1

Member
Oct 10, 2015
93
27
8
AZ
Truck Year
2017
My 2 month old EcoD Laramie went into the ETC code mode when I tried to install the AFE SCorcher tune...the truck tossed the CEL with a z bolt and check engine message, and the truck would only turn over....I took it off ..the truck started but ran in limp mode and the CEL warnings did not clear...drove home ..took of both battery cables waited 5 minutes and re-installed..codes cleared....truck ran fine....no Scorcher being installed now..or ever.
 
  • Like
Reactions: Mharrison

Ofishl1

Member
Oct 10, 2015
93
27
8
AZ
Truck Year
2017
Hope you can return it....I would be chapped if I spent a few hundred bucks on somethinf to realize I can't use it
We will see what happens...
 

yx9229ic

New Member
Jan 19, 2016
6
8
3
Truck Year
2015
I had the "Service Electronic Throttle Control" warning; when I was driving 75 mph on freeway; so I got off at next exit and looked up code in book. Drove 35 mph to dealership and they told me it was an EGR valve, but they were on backorder and would be a few weeks out. So they reset the code and we are all praying it will not repeat. I am going out of town this weekend and pulling a trailer; so hopefully it won't act up again. I have 35,000 miles on it and have replaced the engine due to two spun rod bearing at 29,000 miles. I bought this pickup to replace a 97 Chevy with 200,000 miles on it; but probably would be better off driving the 97 Chevy. I also own a Peterbilt 386 tractor; and have had nothing but EGR issues with that; I am sure glad the government and environmentalists make us drive vehicles with this crapping stuff on them. Sorry about venting.
 

Mharrison

Active Member
Jun 17, 2015
373
105
43
Yuba city, ca
Truck Year
2015
Yes the emissions regulations are crap and only getting worse especially in my poor state. I have been able to provoke a service throttle control light simply by driving with my foot on the gas and brake and that same time for about 5 seconds while I used my 3rd brake light to take a peek at a load that was in my bed. Blues up for a few minutes and went right away never came back.
 
  • Like
Reactions: yx9229ic

ki0eh

New Member
Dec 15, 2015
4
0
1
Truck Year
2015
I had this message at 15k of running beautifully, and went limping. 150 miles from home. Truck would not make the message go away on its own by off/on cycles as suggested in manual. I had it towed to where Chrysler would take it, fortunately in the town where I was spending the night anyway. Dealer next day said it had been filled with "bad biodiesel in the Mid Atlantic" and said they would need to replace the injectors. Rental car over the weekend. Today I got the truck back. They said in addition to the injectors they had done a computer update. On the way home it reported 1.5 mpg more than it had on that trip previously. Asked what I could do to prevent it and they said "it was nothing I did wrong".
 

jdn112011

Well-Known Member
Oct 18, 2015
1,202
310
83
27
Roseau, MN
Truck Year
2015
Wow a dealer did injectors as a weekend job? That's impressive
 

BoostN

Administrator
Staff member
Administrator
Jul 27, 2013
3,744
958
113
Tennessee
ecodieselram.com
Truck Year
Not Listed
I had this message at 15k of running beautifully, and went limping. 150 miles from home. Truck would not make the message go away on its own by off/on cycles as suggested in manual. I had it towed to where Chrysler would take it, fortunately in the town where I was spending the night anyway. Dealer next day said it had been filled with "bad biodiesel in the Mid Atlantic" and said they would need to replace the injectors. Rental car over the weekend. Today I got the truck back. They said in addition to the injectors they had done a computer update. On the way home it reported 1.5 mpg more than it had on that trip previously. Asked what I could do to prevent it and they said "it was nothing I did wrong".
Did they actually replace the injectors under warranty when you had bad fuel (or so they said..)?
 

ki0eh

New Member
Dec 15, 2015
4
0
1
Truck Year
2015
The vehicle got towed in on a Wednesday evening and was done Monday afternoon. No weekend work.

Yes under warranty. I briefly saw the "if it's throwing this series of ungodly codes, do this" sheet before it disappeared under the counter at the dealership.